CVE-2014-0214 Moodle creates a MoodleMobile web-service token with an infinite lifetime
Remote attackers can hijack sessions via brute-force attacks because MoodleMobile web-service tokens have an infinite lifetime.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2014-0214?
CVE-2014-0214 is a medium-severity authentication bypass vulnerability in Moodle Moodle, published on 27 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
login/token.php in Moodle through 2.3.11, 2.4.x before 2.4.10, 2.5.x before 2.5.6, and 2.6.x before 2.6.3 creates a MoodleMobile web-service token with an infinite lifetime, which makes it easier for remote attackers to hijack sessions via a brute-force attack.
Weakness: CWE-287
Which versions are affected by CVE-2014-0214?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.4.10 |
moodle/moodle Packagist | All versions | 2.4.10 |
moodle/moodle Packagist | From 2.5.0 | 2.5.6 |
moodle/moodle Packagist | From 2.5.0 | 2.5.6 |
moodle/moodle Packagist | From 2.6.0 | 2.6.3 |
moodle/moodle Packagist | From 2.6.0 | 2.6.3 |
Products include Moodle Moodle.
How do I fix CVE-2014-0214?
Upgrade moodle/moodle to a fixed version for your release line: 2.4.10, 2.5.6 or 2.6.3.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2014-0214 being exploited?
There is no known exploitation of CVE-2014-0214 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-48rq-vj58-2mh6.