CVE-2014-0215 Moodle Reveals Student Information Meant To Be Anonymous
Authenticated users can de-anonymize student identities in Moodle blind-marking features by inspecting HTML or using screen readers.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2014-0215?
CVE-2014-0215 is a medium-severity vulnerability in Moodle Moodle, published on 27 May 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
The blind-marking implementation in Moodle through 2.3.11, 2.4.x before 2.4.10, 2.5.x before 2.5.6, and 2.6.x before 2.6.3 allows remote authenticated users to de-anonymize student identities by (1) using a screen reader or (2) reading the HTML source.
Weakness: CWE-200
Which versions are affected by CVE-2014-0215?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 2.4.0 | 2.4.10 |
moodle/moodle Packagist | From 2.4.0 | 2.4.10 |
moodle/moodle Packagist | From 2.5.0 | 2.5.6 |
moodle/moodle Packagist | From 2.5.0 | 2.5.6 |
moodle/moodle Packagist | From 2.6.0 | 2.7.0 |
moodle/moodle Packagist | From 2.6.0 | 2.7.0 |
Products include Moodle Moodle.
How do I fix CVE-2014-0215?
Upgrade moodle/moodle to a fixed version for your release line: 2.4.10, 2.5.6 or 2.7.0.
Is CVE-2014-0215 being exploited?
There is no known exploitation of CVE-2014-0215 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-2fmv-j5xj-4fmq.