CVE-2014-0216 Moodle does not properly restrict file access
Remote attackers can access sensitive files in Moodle HTML blocks due to improper access restrictions, requiring low-privilege user interaction.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2014-0216?
CVE-2014-0216 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 27 May 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
The My Home implementation in the block_html_pluginfile function in blocks/html/lib.php in Moodle through 2.3.11, 2.4.x before 2.4.10, 2.5.x before 2.5.6, and 2.6.x before 2.6.3 does not properly restrict file access, which allows remote attackers to obtain sensitive information by visiting an HTML block.
Weakness: CWE-264
Which versions are affected by CVE-2014-0216?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.4.10 |
moodle/moodle Packagist | All versions | 2.4.10 |
moodle/moodle Packagist | From 2.5.0 | 2.5.6 |
moodle/moodle Packagist | From 2.5.0 | 2.5.6 |
moodle/moodle Packagist | From 2.6.0 | 2.6.3 |
moodle/moodle Packagist | From 2.6.0 | 2.6.3 |
Products include Moodle Moodle.
How do I fix CVE-2014-0216?
Upgrade moodle/moodle to a fixed version for your release line: 2.4.10, 2.5.6 or 2.6.3.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2014-0216 being exploited?
There is no known exploitation of CVE-2014-0216 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-8rc7-4qfv-4484.