CVE-2014-0218 Moodle cross-site scripting (XSS) vulnerability
Remote attackers can inject arbitrary web script or HTML into Moodle's URL downloader, potentially compromising user sessions or data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2014-0218?
CVE-2014-0218 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 27 May 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in the URL downloader repository in repository/url/lib.php in Moodle through 2.3.11, 2.4.x before 2.4.10, 2.5.x before 2.5.6, and 2.6.x before 2.6.3 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Weakness: CWE-79
Which versions are affected by CVE-2014-0218?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.4.10 |
moodle/moodle Packagist | All versions | 2.4.10 |
moodle/moodle Packagist | From 2.5.0 | 2.5.6 |
moodle/moodle Packagist | From 2.5.0 | 2.5.6 |
moodle/moodle Packagist | From 2.6.0 | 2.6.3 |
moodle/moodle Packagist | From 2.6.0 | 2.6.3 |
Products include Moodle Moodle.
How do I fix CVE-2014-0218?
Upgrade moodle/moodle to a fixed version for your release line: 2.4.10, 2.5.6 or 2.6.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2014-0218 being exploited?
There is no known exploitation of CVE-2014-0218 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-ch68-5r37-p7c3.