# CVE-2014-0228: Low severity vulnerability that affects org.apache.hive:hive-exec, org.apache.hive:hive, and org.apache.hive:hive-service

> Authenticated users can bypass file permission checks in Hive import/export statements to access sensitive information.

- **Severity:** Low 3.5 (`AV:N/AC:M/Au:S/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Nov 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-w4x9-4f5x-8jj8

## What is CVE-2014-0228?

CVE-2014-0228 is a low-severity missing authorization vulnerability in n/a, published on 16 Nov 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Hive before 0.13.1, when in SQL standards based authorization mode, does not properly check the file permissions for (1) import and (2) export statements, which allows remote authenticated users to obtain sensitive information via a crafted URI.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2014-0228?

6 open source packages ship an affected version, including org.apache.hive:hive, org.apache.hive:hive-exec and org.apache.hive:hive-service. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hive:hive` | Maven | All versions | 0.13.1 |
| `org.apache.hive:hive` | Maven | All versions | 0.13.1 |
| `org.apache.hive:hive-exec` | Maven | All versions | 0.13.1 |
| `org.apache.hive:hive-exec` | Maven | All versions | 0.13.1 |
| `org.apache.hive:hive-service` | Maven | All versions | 0.13.1 |
| `org.apache.hive:hive-service` | Maven | All versions | 0.13.1 |

Products: Apache Hive.

## How do I fix CVE-2014-0228?

Upgrade org.apache.hive:hive to 0.13.1 or later.

## Is CVE-2014-0228 being exploited?

There is no known exploitation of CVE-2014-0228 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-49845](https://insights.sbomify.com/CVE-2026-49845/): Apache Hive: SQL Injection vulnerability in HiveMetaStore partition-name direct-SQL paths (critical 9.8)
- [CVE-2018-21234](https://insights.sbomify.com/CVE-2018-21234/): Deserialization of Untrusted Data in Jodd (critical 9.8)
- [CVE-2026-55976](https://insights.sbomify.com/CVE-2026-55976/): Apache Hive: SSRF vulnerability in Hive Avro Serde due to Insufficient input validation on avro.schema.url (critical 9.1)
- [CVE-2018-1282](https://insights.sbomify.com/CVE-2018-1282/): SQL Injection in hive-jdbc (critical 9.1)
- [CVE-2022-41137](https://insights.sbomify.com/CVE-2022-41137/): Apache Hive: Deserialization of untrusted data when fetching partitions from the Metastore (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0228 and fix it if it is affected.

What it is: CVE-2014-0228 is a low-severity missing authorization vulnerability in n/a, published on 16 Nov 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-0228 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hive:hive (Maven): affected all versions; fixed in 0.13.1
- org.apache.hive:hive (Maven): affected all versions; fixed in 0.13.1
- org.apache.hive:hive-exec (Maven): affected all versions; fixed in 0.13.1
- org.apache.hive:hive-exec (Maven): affected all versions; fixed in 0.13.1
- org.apache.hive:hive-service (Maven): affected all versions; fixed in 0.13.1
- org.apache.hive:hive-service (Maven): affected all versions; fixed in 0.13.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0228/ (Markdown: https://insights.sbomify.com/CVE-2014-0228/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0228
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0228
- OSV: https://osv.dev/vulnerability/CVE-2014-0228

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0228/
Summaries are generated and may contain mistakes; the official description above is the record.
