CVE-2014-0229 Improper Authentication in Apache Hadoop

Medium 6.5 Published Updated

Remote authenticated users can execute unauthorized HDFS admin commands, causing DataNode shutdowns or unnecessary operations due to missing authorization checks.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-0229?

CVE-2014-0229 is a medium-severity missing authorization vulnerability in n/a, published on 23 Mar 2017. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Apache Hadoop 0.23.x before 0.23.11 and 2.x before 2.4.1, as used in Cloudera CDH 5.0.x before 5.0.2, do not check authorization for the (1) refreshNamenodes, (2) deleteBlockPool, and (3) shutdownDatanode HDFS admin commands, which allows remote authenticated users to cause a denial of service (DataNodes shutdown) or perform unnecessary operations by issuing a command.

Weakness: CWE-264

Which versions are affected by CVE-2014-0229?

4 open source packages ship an affected version, including org.apache.hadoop:hadoop-common. It affects 2 products.

PackageAffectedFixed in
org.apache.hadoop:hadoop-common MavenFrom 0.23.00.23.11
org.apache.hadoop:hadoop-common MavenFrom 0.23.00.23.11
org.apache.hadoop:hadoop-common MavenFrom 2.0.02.4.1
org.apache.hadoop:hadoop-common MavenFrom 2.0.02.4.1

Products include Apache Hadoop, Cloudera Cdh.

How do I fix CVE-2014-0229?

Upgrade org.apache.hadoop:hadoop-common to a fixed version for your release line: 0.23.11 or 2.4.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2014-0229 being exploited?

There is no known exploitation of CVE-2014-0229 in the wild and no public exploit code.

Sources

Also known as GHSA-9r7g-325h-mxrm.

Is CVE-2014-0229 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free