# CVE-2014-0229: Improper Authentication in Apache Hadoop

> Remote authenticated users can execute unauthorized HDFS admin commands, causing DataNode shutdowns or unnecessary operations due to missing authorization checks.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Mar 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-9r7g-325h-mxrm

## What is CVE-2014-0229?

CVE-2014-0229 is a medium-severity missing authorization vulnerability in n/a, published on 23 Mar 2017. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Hadoop 0.23.x before 0.23.11 and 2.x before 2.4.1, as used in Cloudera CDH 5.0.x before 5.0.2, do not check authorization for the (1) refreshNamenodes, (2) deleteBlockPool, and (3) shutdownDatanode HDFS admin commands, which allows remote authenticated users to cause a denial of service (DataNodes shutdown) or perform unnecessary operations by issuing a command.

Weakness: CWE-264

## Which versions are affected by CVE-2014-0229?

4 open source packages ship an affected version, including org.apache.hadoop:hadoop-common. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hadoop:hadoop-common` | Maven | From 0.23.0 | 0.23.11 |
| `org.apache.hadoop:hadoop-common` | Maven | From 0.23.0 | 0.23.11 |
| `org.apache.hadoop:hadoop-common` | Maven | From 2.0.0 | 2.4.1 |
| `org.apache.hadoop:hadoop-common` | Maven | From 2.0.0 | 2.4.1 |

Products: Apache Hadoop, Cloudera Cdh.

## How do I fix CVE-2014-0229?

Upgrade org.apache.hadoop:hadoop-common to a fixed version for your release line: 0.23.11 or 2.4.1.

## Is CVE-2014-0229 being exploited?

There is no known exploitation of CVE-2014-0229 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-25168](https://insights.sbomify.com/CVE-2022-25168/): Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar (critical 9.8)
- [CVE-2021-37404](https://insights.sbomify.com/CVE-2021-37404/): Heap buffer overflow in libhdfs native library (critical 9.8)
- [CVE-2022-26612](https://insights.sbomify.com/CVE-2022-26612/): Arbitrary file write in FileUtil#unpackEntries on Windows (critical 9.8)
- [CVE-2019-17195](https://insights.sbomify.com/CVE-2019-17195/): Improper Check for Unusual or Exceptional Conditions in Connect2id Nimbus JOSE+JWT (critical 9.8)
- [CVE-2017-15718](https://insights.sbomify.com/CVE-2017-15718/): Exposure of Sensitive Information in Hadoop (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0229 and fix it if it is affected.

What it is: CVE-2014-0229 is a medium-severity missing authorization vulnerability in n/a, published on 23 Mar 2017. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-0229 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hadoop:hadoop-common (Maven): affected from 0.23.0; fixed in 0.23.11
- org.apache.hadoop:hadoop-common (Maven): affected from 0.23.0; fixed in 0.23.11
- org.apache.hadoop:hadoop-common (Maven): affected from 2.0.0; fixed in 2.4.1
- org.apache.hadoop:hadoop-common (Maven): affected from 2.0.0; fixed in 2.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0229/ (Markdown: https://insights.sbomify.com/CVE-2014-0229/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0229
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0229
- OSV: https://osv.dev/vulnerability/CVE-2014-0229

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0229/
Summaries are generated and may contain mistakes; the official description above is the record.
