CVE-2014-0230 Uncontrolled Resource Consumption in Apache Tomcat
Remote attackers can cause denial of service in Apache Tomcat by sending aborted upload requests, consuming server threads.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2014-0230?
CVE-2014-0230 is a high-severity denial of service vulnerability in Apache Tomcat, published on 7 Jun 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache Tomcat 6.x before 6.0.44, 7.x before 7.0.55, and 8.x before 8.0.9 does not properly handle cases where an HTTP response occurs before finishing the reading of an entire request body, which allows remote attackers to cause a denial of service (thread consumption) via a series of aborted upload attempts.
Weakness: CWE-399
Which versions are affected by CVE-2014-0230?
6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.44 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.44 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.55 |
org.apache.tomcat:tomcat Maven | From 7.0.0 | 7.0.55 |
org.apache.tomcat:tomcat Maven | From 8.0.0 | 8.0.9 |
org.apache.tomcat:tomcat Maven | From 8.0.0 | 8.0.9 |
Products include Apache Tomcat, Oracle Virtualization.
How do I fix CVE-2014-0230?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 6.0.44, 7.0.55 or 8.0.9.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2014-0230 being exploited?
There is no known exploitation of CVE-2014-0230 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as GHSA-pxcx-cxq8-4mmw, UBUNTU-CVE-2014-0230.