# CVE-2014-0472: Code Injection in Django

> Remote attackers can execute arbitrary Python code by exploiting URL construction with user-controlled dotted paths in Django applications.

- **Severity:** Medium 5.1 (`AV:N/AC:H/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Apr 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-0472, GHSA-rvq6-mrpv-m6rm, PYSEC-2014-1, UBUNTU-CVE-2014-0472, USN-2169-2

## What is CVE-2014-0472?

CVE-2014-0472 is a medium-severity code injection vulnerability in Canonical Ubuntu Linux, published on 23 Apr 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The django.core.urlresolvers.reverse function in Django before 1.4.11, 1.5.x before 1.5.6, 1.6.x before 1.6.3, and 1.7.x before 1.7 beta 2 allows remote attackers to import and execute arbitrary Python modules by leveraging a view that constructs URLs using user input and a "dotted Python path."

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2014-0472?

7 open source packages ship an affected version, including django and Django. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | All versions | 1.4.11, 1.5.6, 1.6.3 |
| `django` | PyPI | All versions | 1.4.11 |
| `django` | PyPI | From 1.5 | 1.5.6 |
| `django` | PyPI | From 1.6 | 1.6.3 |
| `Django` | PyPI | All versions | 1.4.11 |
| `Django` | PyPI | From 1.5 | 1.5.6 |
| `Django` | PyPI | From 1.6 | 1.6.3 |

Products: Canonical Ubuntu Linux, Djangoproject Django.

## How do I fix CVE-2014-0472?

Upgrade django to a fixed version for your release line: 1.4.11, 1.5.6 or 1.6.3.

## Is CVE-2014-0472 being exploited?

There is no known exploitation of CVE-2014-0472 in the wild and no public exploit code.

Public exploit code:

- CVE-2014-0472 Django unexpected code execution using reverse() (github_poc): https://github.com/christasa/CVE-2014-0472

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0472 and fix it if it is affected.

What it is: CVE-2014-0472 is a medium-severity code injection vulnerability in Canonical Ubuntu Linux, published on 23 Apr 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-0472 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (PyPI): affected all versions; fixed in 1.4.11, 1.5.6, 1.6.3
- django (PyPI): affected all versions; fixed in 1.4.11
- django (PyPI): affected from 1.5; fixed in 1.5.6
- django (PyPI): affected from 1.6; fixed in 1.6.3
- Django (PyPI): affected all versions; fixed in 1.4.11
- Django (PyPI): affected from 1.5; fixed in 1.5.6
- Django (PyPI): affected from 1.6; fixed in 1.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0472/ (Markdown: https://insights.sbomify.com/CVE-2014-0472/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0472
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0472
- OSV: https://osv.dev/vulnerability/CVE-2014-0472

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0472/
Summaries are generated and may contain mistakes; the official description above is the record.
