CVE-2014-0473 Django Reuses Cached CSRF Token
Remote attackers can bypass CSRF protections by reusing cached tokens for anonymous users, requiring user interaction to exploit.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2014-0473?
CVE-2014-0473 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 23 Apr 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
The caching framework in Django before 1.4.11, 1.5.x before 1.5.6, 1.6.x before 1.6.3, and 1.7.x before 1.7 beta 2 reuses a cached CSRF token for all anonymous users, which allows remote attackers to bypass CSRF protections by reading the CSRF cookie for anonymous users.
Weakness: CWE-264
Which versions are affected by CVE-2014-0473?
7 open source packages ship an affected version, including django and Django. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
django PyPI | All versions | 1.4.11, 1.5.6, 1.6.3 |
django PyPI | All versions | 1.4.11 |
django PyPI | From 1.5 | 1.5.6 |
django PyPI | From 1.6 | 1.6.3 |
Django PyPI | All versions | 1.4.11 |
Django PyPI | From 1.5 | 1.5.6 |
1 more packages
Django PyPI | From 1.6 | 1.6.3 |
Products include Canonical Ubuntu Linux, Djangoproject Django.
How do I fix CVE-2014-0473?
Upgrade django to a fixed version for your release line: 1.4.11, 1.5.6 or 1.6.3.
Is CVE-2014-0473 being exploited?
There is no known exploitation of CVE-2014-0473 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as DEBIAN-CVE-2014-0473, GHSA-89hj-xfx5-7q66, PYSEC-2014-2, UBUNTU-CVE-2014-0473.