CVE-2014-0474 Django Vulnerable to MySQL Injection
Improper type conversion in Django model fields allows remote attackers to exploit MySQL typecasting issues, potentially leading to unspecified impacts.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2014-0474?
CVE-2014-0474 is a critical vulnerability in Canonical Ubuntu Linux, published on 23 Apr 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The (1) FilePathField, (2) GenericIPAddressField, and (3) IPAddressField model field classes in Django before 1.4.11, 1.5.x before 1.5.6, 1.6.x before 1.6.3, and 1.7.x before 1.7 beta 2 do not properly perform type conversion, which allows remote attackers to have unspecified impact and vectors, related to "MySQL typecasting."
Weakness: CWE-399
Which versions are affected by CVE-2014-0474?
7 open source packages ship an affected version, including django and Django. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
django PyPI | All versions | 1.4.11, 1.5.6, 1.6.3 |
django PyPI | All versions | 1.4.11 |
django PyPI | From 1.5 | 1.5.6 |
django PyPI | From 1.6 | 1.6.3 |
Django PyPI | All versions | 1.4.11 |
Django PyPI | From 1.5 | 1.5.6 |
1 more packages
Django PyPI | From 1.6 | 1.6.3 |
Products include Canonical Ubuntu Linux, Djangoproject Django.
How do I fix CVE-2014-0474?
Upgrade django to a fixed version for your release line: 1.4.11, 1.5.6 or 1.6.3.
Is CVE-2014-0474 being exploited?
There is no known exploitation of CVE-2014-0474 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as DEBIAN-CVE-2014-0474, GHSA-wqjj-hx84-v449, PYSEC-2014-3, UBUNTU-CVE-2014-0474.