CVE-2014-0481 Django denial of service via file upload naming
Remote attackers can cause denial of service via CPU exhaustion by uploading multiple files with identical names in Django's default file upload configuration.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2014-0481?
CVE-2014-0481 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 26 Aug 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The default configuration for the file upload handling system in Django before 1.4.14, 1.5.x before 1.5.9, 1.6.x before 1.6.6, and 1.7 before release candidate 3 uses a sequential file name generation process when a file with a conflicting name is uploaded, which allows remote attackers to cause a denial of service (CPU consumption) by unloading a multiple files with the same name.
Weakness: CWE-399
Which versions are affected by CVE-2014-0481?
7 open source packages ship an affected version, including django and Django. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
django PyPI | All versions | 1.4.14, 1.5.9, 1.6.6 |
django PyPI | All versions | 1.4.14 |
django PyPI | From 1.5 | 1.5.9 |
django PyPI | From 1.6 | 1.6.6 |
Django PyPI | All versions | 1.4.14 |
Django PyPI | From 1.5 | 1.5.9 |
1 more packages
Django PyPI | From 1.6 | 1.6.6 |
Products include Debian Debian Linux, Djangoproject Django, Opensuse Opensuse, Opensuse Project Opensuse.
How do I fix CVE-2014-0481?
Upgrade django to a fixed version for your release line: 1.4.14, 1.5.9 or 1.6.6.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2014-0481 being exploited?
There is no known exploitation of CVE-2014-0481 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2014-0481, GHSA-296w-6qhq-gf92, PYSEC-2014-5, UBUNTU-CVE-2014-0481.