# CVE-2014-0481: Django denial of service via file upload naming

> Remote attackers can cause denial of service via CPU exhaustion by uploading multiple files with identical names in Django's default file upload configuration.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Aug 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-0481, GHSA-296w-6qhq-gf92, PYSEC-2014-5, UBUNTU-CVE-2014-0481

## What is CVE-2014-0481?

CVE-2014-0481 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 26 Aug 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The default configuration for the file upload handling system in Django before 1.4.14, 1.5.x before 1.5.9, 1.6.x before 1.6.6, and 1.7 before release candidate 3 uses a sequential file name generation process when a file with a conflicting name is uploaded, which allows remote attackers to cause a denial of service (CPU consumption) by unloading a multiple files with the same name.

Weakness: CWE-399

## Which versions are affected by CVE-2014-0481?

7 open source packages ship an affected version, including django and Django. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | All versions | 1.4.14, 1.5.9, 1.6.6 |
| `django` | PyPI | All versions | 1.4.14 |
| `django` | PyPI | From 1.5 | 1.5.9 |
| `django` | PyPI | From 1.6 | 1.6.6 |
| `Django` | PyPI | All versions | 1.4.14 |
| `Django` | PyPI | From 1.5 | 1.5.9 |
| `Django` | PyPI | From 1.6 | 1.6.6 |

Products: Debian Debian Linux, Djangoproject Django, Opensuse Opensuse, Opensuse Project Opensuse.

## How do I fix CVE-2014-0481?

Upgrade django to a fixed version for your release line: 1.4.14, 1.5.9 or 1.6.6.

## Is CVE-2014-0481 being exploited?

There is no known exploitation of CVE-2014-0481 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0481 and fix it if it is affected.

What it is: CVE-2014-0481 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 26 Aug 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-0481 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (PyPI): affected all versions; fixed in 1.4.14, 1.5.9, 1.6.6
- django (PyPI): affected all versions; fixed in 1.4.14
- django (PyPI): affected from 1.5; fixed in 1.5.9
- django (PyPI): affected from 1.6; fixed in 1.6.6
- Django (PyPI): affected all versions; fixed in 1.4.14
- Django (PyPI): affected from 1.5; fixed in 1.5.9
- Django (PyPI): affected from 1.6; fixed in 1.6.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0481/ (Markdown: https://insights.sbomify.com/CVE-2014-0481/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0481
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0481
- OSV: https://osv.dev/vulnerability/CVE-2014-0481

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0481/
Summaries are generated and may contain mistakes; the official description above is the record.
