# CVE-2014-0482: Django Middleware Enables Session Hijacking

> Authenticated users can hijack web sessions in Django applications using RemoteUserMiddleware and RemoteUserBackend, leading to account takeover.

- **Severity:** Medium 6.0 (`AV:N/AC:M/Au:S/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Aug 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-0482, GHSA-625g-gx8c-xcmg, PYSEC-2014-6, UBUNTU-CVE-2014-0482

## What is CVE-2014-0482?

CVE-2014-0482 is a medium-severity authentication bypass vulnerability in Djangoproject Django, published on 26 Aug 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The contrib.auth.middleware.RemoteUserMiddleware middleware in Django before 1.4.14, 1.5.x before 1.5.9, 1.6.x before 1.6.6, and 1.7 before release candidate 3, when using the contrib.auth.backends.RemoteUserBackend backend, allows remote authenticated users to hijack web sessions via vectors related to the REMOTE_USER header.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2014-0482?

9 open source packages ship an affected version, including django and Django. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | All versions | 1.4.14, 1.5.9, 1.6.6 |
| `django` | PyPI | All versions | 1.4.14 |
| `django` | PyPI | From 1.5 | 1.5.9 |
| `django` | PyPI | From 1.6 | 1.6.6 |
| `django` | PyPI | From 1.7a1 | 1.7c3 |
| `Django` | PyPI | All versions | 1.4.14 |
| `Django` | PyPI | From 1.5 | 1.5.9 |
| `Django` | PyPI | From 1.6 | 1.6.6 |
| `Django` | PyPI | From 1.7a1 | 1.7c3 |

Products: Djangoproject Django, Opensuse Opensuse.

## How do I fix CVE-2014-0482?

Upgrade django to a fixed version for your release line: 1.4.14, 1.5.9, 1.6.6 or 1.7c3.

## Is CVE-2014-0482 being exploited?

There is no known exploitation of CVE-2014-0482 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0482 and fix it if it is affected.

What it is: CVE-2014-0482 is a medium-severity authentication bypass vulnerability in Djangoproject Django, published on 26 Aug 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-0482 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (PyPI): affected all versions; fixed in 1.4.14, 1.5.9, 1.6.6
- django (PyPI): affected all versions; fixed in 1.4.14
- django (PyPI): affected from 1.5; fixed in 1.5.9
- django (PyPI): affected from 1.6; fixed in 1.6.6
- django (PyPI): affected from 1.7a1; fixed in 1.7c3
- Django (PyPI): affected all versions; fixed in 1.4.14
- Django (PyPI): affected from 1.5; fixed in 1.5.9
- Django (PyPI): affected from 1.6; fixed in 1.6.6
- Django (PyPI): affected from 1.7a1; fixed in 1.7c3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0482/ (Markdown: https://insights.sbomify.com/CVE-2014-0482/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0482
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0482
- OSV: https://osv.dev/vulnerability/CVE-2014-0482

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0482/
Summaries are generated and may contain mistakes; the official description above is the record.
