{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-0593 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2014-0593 is a high-severity command injection vulnerability in openSUSE obs-service-set_version, published on 8 Jun 2018. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-0593 and fix it if it is affected.\n\nWhat it is: CVE-2014-0593 is a high-severity command injection vulnerability in openSUSE obs-service-set_version, published on 8 Jun 2018. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-0593 in the wild and no public exploit code.\n\nAffected product: openSUSE obs-service-set_version. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-0593/ (Markdown: https://insights.sbomify.com/CVE-2014-0593/index.md)","id":"CVE-2014-0593","markdown":"https://insights.sbomify.com/CVE-2014-0593/index.md","name":"CVE-2014-0593","record":{"aliases":["GHSA-h8fh-v5gw-ch7g","openSUSE-SU-2024:10108-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Open Build Service tool","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary code on the server via unsanitized input in the set_version script of the Open Build Service.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"microfocus","cpe":[{"product":"open_build_service","vendor":"opensuse"}],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"},{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"The set_version script as shipped with obs-service-set_version is a source validator for the Open Build Service (OBS). In versions prior to 0.5.3-1.1 this script did not properly sanitize the input provided by the user, allowing for code execution on the executing server.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"sed command injection","id":"CVE-2014-0593","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2014"},"n_packages":1,"n_references":4,"next":{"headline":"CSRF protection incorrectly disabled","id":"CVE-2014-0594"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.5.3-4.2"],"introduced":["0"],"last_affected":[],"package":"obs-service-set_version","purl":"pkg:rpm/opensuse/obs-service-set_version\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10108-1"}],"prev":{"headline":"Security feature bypass in n/a","id":"CVE-2014-0592"},"products":["obs-service-set_version"],"published":"2018-06-08","related":[{"cvss_score":8.8,"headline":"Multiple XXE vulnerabilities in OBS","id":"CVE-2022-21949","kev_date_added":null,"published":"2022-05-03"},{"cvss_score":8.8,"headline":"No write permission check in change_role command","id":"CVE-2013-3703","kev_date_added":null,"published":"2018-06-08"},{"cvss_score":8.8,"headline":"CSRF protection incorrectly disabled","id":"CVE-2014-0594","kev_date_added":null,"published":"2018-06-08"},{"cvss_score":8.1,"headline":"login-proxy sends password to attacker-provided domain","id":"CVE-2021-36777","kev_date_added":null,"published":"2022-03-09"},{"cvss_score":8.1,"headline":"openbuildservice webui code injection","id":"CVE-2011-3178","kev_date_added":null,"published":"2018-03-20"},{"cvss_score":7.4,"headline":"Missing TLS certificate validation for HTTPS connections in osc","id":"CVE-2019-3685","kev_date_added":null,"published":"2019-11-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["openSUSE"]},"summary":"Attackers can execute arbitrary code on the server via unsanitized input in the set_version script of the Open Build Service.","url":"https://insights.sbomify.com/CVE-2014-0593/"}