# CVE-2014-0808: EC-CUBE vulnerable to authorization bypass

> Attackers can access other users' information by sending crafted HTTP requests due to an authorization bypass in EC-CUBE.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-j2hg-w4p4-6rvm

## What is CVE-2014-0808?

CVE-2014-0808 is a critical missing authorization vulnerability in EC-CUBE, published on 22 Jan 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Authorization bypass through user-controlled key issue exists in EC-CUBE 2.11.0 through 2.12.2 and EC-Orange systems deployed before June 29th, 2015. If this vulnerability is exploited, a user of the affected shopping website may obtain other users' information by sending a crafted HTTP request.

Weakness: CWE-566 (Authorization Bypass Through User-Controlled SQL Primary Key)

## Which versions are affected by CVE-2014-0808?

2 open source packages ship an affected version, including ec-cube/ec-cube. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ec-cube/ec-cube` | Packagist | From 2.11.0 | 2.12.2 |
| `ec-cube/ec-cube` | Packagist | From 2.11.0 | 2.12.2 |

Products: Lockon Ec-Cube.

## How do I fix CVE-2014-0808?

Upgrade ec-cube/ec-cube to 2.12.2 or later.

## Is CVE-2014-0808 being exploited?

There is no known exploitation of CVE-2014-0808 in the wild and no public exploit code.

## Other vulnerabilities in EC-CUBE

- [CVE-2016-1201](https://insights.sbomify.com/CVE-2016-1201/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2018-0564](https://insights.sbomify.com/CVE-2018-0564/): Other in EC-CUBE (high 8.1)
- [CVE-2013-3651](https://insights.sbomify.com/CVE-2013-3651/): Code injection in n/a (high 7.5)
- [CVE-2011-3988](https://insights.sbomify.com/CVE-2011-3988/): SQL injection in n/a (high 7.5)
- [CVE-2013-5993](https://insights.sbomify.com/CVE-2013-5993/): Cross-site request forgery in n/a (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-0808 and fix it if it is affected.

What it is: CVE-2014-0808 is a critical missing authorization vulnerability in EC-CUBE, published on 22 Jan 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-0808 in the wild and no public exploit code.

Affected packages and fixed versions:
- ec-cube/ec-cube (Packagist): affected from 2.11.0; fixed in 2.12.2
- ec-cube/ec-cube (Packagist): affected from 2.11.0; fixed in 2.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-0808/ (Markdown: https://insights.sbomify.com/CVE-2014-0808/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-0808
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-0808
- OSV: https://osv.dev/vulnerability/CVE-2014-0808

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-0808/
Summaries are generated and may contain mistakes; the official description above is the record.
