{"answers":{"affected":"2 open source packages ship an affected version, including fancy-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-10066 in the wild and no public exploit code.","fix":"Upgrade fancy-server to 0.1.4 or later.","what":"CVE-2014-10066 is a high-severity path traversal vulnerability in HackerOne fancy-server node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-10066 and fix it if it is affected.\n\nWhat it is: CVE-2014-10066 is a high-severity path traversal vulnerability in HackerOne fancy-server node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-10066 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fancy-server (npm): affected all versions; fixed in 0.1.4\n- fancy-server (npm): affected all versions; fixed in 0.1.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-10066/ (Markdown: https://insights.sbomify.com/CVE-2014-10066/index.md)","id":"CVE-2014-10066","markdown":"https://insights.sbomify.com/CVE-2014-10066/index.md","name":"CVE-2014-10066","record":{"aliases":["GHSA-m273-wwfv-h6jp"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js static file server","requires_auth":"none","summary":"An attacker can read files outside the served directory in the fancy-server Node.js module by using directory traversal sequences.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"fancy-server","vendor":"fancy-server_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Versions less than 0.1.4 of the static file server module fancy-server are vulnerable to directory traversal. An attacker can provide input such as `../` to read files outside of the served directory.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Directory Traversal in fancy-server","id":"CVE-2014-10066","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2014"},"n_packages":2,"n_references":1,"next":{"headline":"Validation Bypass in paypal-ipn","id":"CVE-2014-10067"},"packages":[{"ecosystem":"npm","fixed":["0.1.4"],"introduced":["0"],"last_affected":[],"package":"fancy-server","purl":null,"source":"GHSA-m273-wwfv-h6jp"},{"ecosystem":"npm","fixed":["0.1.4"],"introduced":["0"],"last_affected":[],"package":"fancy-server","purl":"pkg:npm/fancy-server","source":"GHSA-m273-wwfv-h6jp"}],"prev":{"headline":"Content Injection in remarkable","id":"CVE-2014-10065"},"products":["fancy-server node module"],"published":"2018-05-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["HackerOne"]},"summary":"An attacker can read files outside the served directory in the fancy-server Node.js module by using directory traversal sequences.","url":"https://insights.sbomify.com/CVE-2014-10066/"}