# CVE-2014-10066: Directory Traversal in fancy-server

> An attacker can read files outside the served directory in the fancy-server Node.js module by using directory traversal sequences.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-m273-wwfv-h6jp

## What is CVE-2014-10066?

CVE-2014-10066 is a high-severity path traversal vulnerability in HackerOne fancy-server node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions less than 0.1.4 of the static file server module fancy-server are vulnerable to directory traversal. An attacker can provide input such as `../` to read files outside of the served directory.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2014-10066?

2 open source packages ship an affected version, including fancy-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fancy-server` | npm | All versions | 0.1.4 |
| `fancy-server` | npm | All versions | 0.1.4 |

Products: Fancy-Server Project Fancy-Server.

## How do I fix CVE-2014-10066?

Upgrade fancy-server to 0.1.4 or later.

## Is CVE-2014-10066 being exploited?

There is no known exploitation of CVE-2014-10066 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-10066 and fix it if it is affected.

What it is: CVE-2014-10066 is a high-severity path traversal vulnerability in HackerOne fancy-server node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-10066 in the wild and no public exploit code.

Affected packages and fixed versions:
- fancy-server (npm): affected all versions; fixed in 0.1.4
- fancy-server (npm): affected all versions; fixed in 0.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-10066/ (Markdown: https://insights.sbomify.com/CVE-2014-10066/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-10066
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-10066
- OSV: https://osv.dev/vulnerability/CVE-2014-10066

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-10066/
Summaries are generated and may contain mistakes; the official description above is the record.
