{"answers":{"affected":"2 open source packages ship an affected version, including paypal-ipn. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-10067 in the wild and no public exploit code.","fix":"Upgrade paypal-ipn to 3.0.0 or later.","what":"CVE-2014-10067 is a medium-severity authentication bypass vulnerability in HackerOne paypal-ipn node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-10067 and fix it if it is affected.\n\nWhat it is: CVE-2014-10067 is a medium-severity authentication bypass vulnerability in HackerOne paypal-ipn node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-10067 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- paypal-ipn (npm): affected all versions; fixed in 3.0.0\n- paypal-ipn (npm): affected all versions; fixed in 3.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-10067/ (Markdown: https://insights.sbomify.com/CVE-2014-10067/index.md)","id":"CVE-2014-10067","markdown":"https://insights.sbomify.com/CVE-2014-10067/index.md","name":"CVE-2014-10067","record":{"aliases":["GHSA-h698-r4hm-w94p"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PayPal IPN library","requires_auth":"none","summary":"An attacker can bypass production validation by spoofing test parameters, allowing unauthorized transaction processing in applications using the PayPal IPN library.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"paypal-ipn","vendor":"paypal-ipn_project"}],"cvss":{"score":5.9,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"paypal-ipn before 3.0.0 uses the `test_ipn` parameter (which is set by the PayPal IPN simulator) to determine if it should use the production PayPal site or the sandbox. With a bit of time, an attacker could craft a request using the simulator that would fool any application which does not explicitly check for test_ipn in production.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Validation Bypass in paypal-ipn","id":"CVE-2014-10067","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2014"},"n_packages":2,"n_references":2,"next":{"headline":"Hidden Directories Always Served in inert","id":"CVE-2014-10068"},"packages":[{"ecosystem":"npm","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"paypal-ipn","purl":null,"source":"GHSA-h698-r4hm-w94p"},{"ecosystem":"npm","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"paypal-ipn","purl":"pkg:npm/paypal-ipn","source":"GHSA-h698-r4hm-w94p"}],"prev":{"headline":"Directory Traversal in fancy-server","id":"CVE-2014-10066"},"products":["paypal-ipn node module"],"published":"2018-05-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"An attacker can bypass production validation by spoofing test parameters, allowing unauthorized transaction processing in applications using the PayPal IPN library.","url":"https://insights.sbomify.com/CVE-2014-10067/"}