# CVE-2014-10077: i18n Vulnerable to Denial of Service Attack

> Remote attackers can crash Ruby applications using the i18n gem by triggering a specific hash slice condition.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Nov 2018
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-10077, DLA-1584-1, GHSA-34hf-g744-jw64, MGASA-2018-0491, UBUNTU-CVE-2014-10077

## What is CVE-2014-10077?

CVE-2014-10077 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 6 Nov 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hash#slice in lib/i18n/core_ext/hash.rb in the i18n gem before 0.8.0 for Ruby allows remote attackers to cause a denial of service (application crash) via a call in a situation where :some_key is present in keep_keys but not present in the hash.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2014-10077?

2 open source packages ship an affected version, including i18n. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `i18n` | RubyGems | All versions | 0.8.0 |
| `i18n` | RubyGems | All versions | 0.8.0 |

Products: Debian Debian Linux, I18n Project I18n.

## How do I fix CVE-2014-10077?

Upgrade i18n to 0.8.0 or later.

## Is CVE-2014-10077 being exploited?

There is no known exploitation of CVE-2014-10077 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-10077 and fix it if it is affected.

What it is: CVE-2014-10077 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 6 Nov 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-10077 in the wild and no public exploit code.

Affected packages and fixed versions:
- i18n (RubyGems): affected all versions; fixed in 0.8.0
- i18n (RubyGems): affected all versions; fixed in 0.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-10077/ (Markdown: https://insights.sbomify.com/CVE-2014-10077/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-10077
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-10077
- OSV: https://osv.dev/vulnerability/CVE-2014-10077

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-10077/
Summaries are generated and may contain mistakes; the official description above is the record.
