# CVE-2014-125029: ttskch PaginationServiceProvider Demo index.php sql injection


- **Severity:** Medium 5.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 7 Jan 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-ww43-mcvh-35p4

## What is CVE-2014-125029?

CVE-2014-125029 is a medium-severity vulnerability in ttskch PaginationServiceProvider, published on 7 Jan 2023. 

### Official description

A vulnerability was found in ttskch PaginationServiceProvider up to 0.x. It has been declared as critical. This vulnerability affects unknown code of the file demo/index.php of the component demo. The manipulation of the argument sort/id leads to sql injection. Upgrading to version 1.0.0 is able to address this issue. The patch is identified as 619de478efce17ece1a3b913ab16e40651e1ea7b. It is recommended to upgrade the affected component. VDB-217150 is the identifier assigned to this vulnerability.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2014-125029?

2 open source packages ship an affected version, including ttskch/pagination-service-provider. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ttskch/pagination-service-provider` | Packagist | All versions | 1.0.0 |
| `ttskch/pagination-service-provider` | Packagist | All versions | 1.0.0 |

Products: Paginationserviceprovider Project Paginationserviceprovider.

## How do I fix CVE-2014-125029?

Upgrade ttskch/pagination-service-provider to 1.0.0 or later.

## Is CVE-2014-125029 being exploited?

There is no known exploitation of CVE-2014-125029 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-125029 and fix it if it is affected.

What it is: CVE-2014-125029 is a medium-severity vulnerability in ttskch PaginationServiceProvider, published on 7 Jan 2023. 
Exploitation: There is no known exploitation of CVE-2014-125029 in the wild and no public exploit code.

Affected packages and fixed versions:
- ttskch/pagination-service-provider (Packagist): affected all versions; fixed in 1.0.0
- ttskch/pagination-service-provider (Packagist): affected all versions; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-125029/ (Markdown: https://insights.sbomify.com/CVE-2014-125029/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-125029
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-125029
- OSV: https://osv.dev/vulnerability/CVE-2014-125029

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-125029/
Summaries are generated and may contain mistakes; the official description above is the record.
