{"answers":{"affected":"2 open source packages ship an affected version, including himiklab/yii2-jqgrid-widget. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-125051 in the wild and no public exploit code.","fix":"Upgrade himiklab/yii2-jqgrid-widget to 1.0.8 or later.","what":"CVE-2014-125051 is a medium-severity SQL injection vulnerability in himiklab yii2-jqgrid-widget, published on 6 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-125051 and fix it if it is affected.\n\nWhat it is: CVE-2014-125051 is a medium-severity SQL injection vulnerability in himiklab yii2-jqgrid-widget, published on 6 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-125051 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- himiklab/yii2-jqgrid-widget (Packagist): affected all versions; fixed in 1.0.8\n- himiklab/yii2-jqgrid-widget (Packagist): affected all versions; fixed in 1.0.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-125051/ (Markdown: https://insights.sbomify.com/CVE-2014-125051/index.md)","id":"CVE-2014-125051","markdown":"https://insights.sbomify.com/CVE-2014-125051/index.md","name":"CVE-2014-125051","record":{"aliases":["GHSA-7mg5-rw39-q67f"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Yii2 JqGrid widget","requires_auth":"low_privilege","summary":"An attacker can execute arbitrary SQL commands via the addSearchOptionsRecursively function in the himiklab yii2-jqgrid-widget library.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"yii2-jqgrid-widget","vendor":"yii2-jqgrid-widget_project"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"A vulnerability was found in himiklab yii2-jqgrid-widget up to 1.0.7. It has been declared as critical. This vulnerability affects the function addSearchOptionsRecursively of the file JqGridAction.php. The manipulation leads to sql injection. Upgrading to version 1.0.8 is able to address this issue. The name of the patch is a117e0f2df729e3ff726968794d9a5ac40e660b9. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217564.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"himiklab yii2-jqgrid-widget JqGridAction.php addSearchOptionsRecursively sql injection","id":"CVE-2014-125051","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"sql_injection","year":"2014"},"n_packages":2,"n_references":4,"next":{"headline":"JervenBolleman sparql-identifiers RegistryDao.java sql injection","id":"CVE-2014-125052"},"packages":[{"ecosystem":"Packagist","fixed":["1.0.8"],"introduced":["0"],"last_affected":[],"package":"himiklab/yii2-jqgrid-widget","purl":null,"source":"GHSA-7mg5-rw39-q67f"},{"ecosystem":"Packagist","fixed":["1.0.8"],"introduced":["0"],"last_affected":[],"package":"himiklab/yii2-jqgrid-widget","purl":"pkg:composer/himiklab/yii2-jqgrid-widget","source":"GHSA-7mg5-rw39-q67f"}],"prev":{"headline":"ScottTZhang voter-js main.js sql injection","id":"CVE-2014-125050"},"products":["yii2-jqgrid-widget"],"published":"2023-01-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["himiklab"]},"summary":"An attacker can execute arbitrary SQL commands via the addSearchOptionsRecursively function in the himiklab yii2-jqgrid-widget library.","url":"https://insights.sbomify.com/CVE-2014-125051/"}