# CVE-2014-125051: himiklab yii2-jqgrid-widget JqGridAction.php addSearchOptionsRecursively sql injection

> An attacker can execute arbitrary SQL commands via the addSearchOptionsRecursively function in the himiklab yii2-jqgrid-widget library.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jan 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-7mg5-rw39-q67f

## What is CVE-2014-125051?

CVE-2014-125051 is a medium-severity SQL injection vulnerability in himiklab yii2-jqgrid-widget, published on 6 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in himiklab yii2-jqgrid-widget up to 1.0.7. It has been declared as critical. This vulnerability affects the function addSearchOptionsRecursively of the file JqGridAction.php. The manipulation leads to sql injection. Upgrading to version 1.0.8 is able to address this issue. The name of the patch is a117e0f2df729e3ff726968794d9a5ac40e660b9. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217564.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2014-125051?

2 open source packages ship an affected version, including himiklab/yii2-jqgrid-widget. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `himiklab/yii2-jqgrid-widget` | Packagist | All versions | 1.0.8 |
| `himiklab/yii2-jqgrid-widget` | Packagist | All versions | 1.0.8 |

Products: Yii2-Jqgrid-Widget Project Yii2-Jqgrid-Widget.

## How do I fix CVE-2014-125051?

Upgrade himiklab/yii2-jqgrid-widget to 1.0.8 or later.

## Is CVE-2014-125051 being exploited?

There is no known exploitation of CVE-2014-125051 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-125051 and fix it if it is affected.

What it is: CVE-2014-125051 is a medium-severity SQL injection vulnerability in himiklab yii2-jqgrid-widget, published on 6 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-125051 in the wild and no public exploit code.

Affected packages and fixed versions:
- himiklab/yii2-jqgrid-widget (Packagist): affected all versions; fixed in 1.0.8
- himiklab/yii2-jqgrid-widget (Packagist): affected all versions; fixed in 1.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-125051/ (Markdown: https://insights.sbomify.com/CVE-2014-125051/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-125051
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-125051
- OSV: https://osv.dev/vulnerability/CVE-2014-125051

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-125051/
Summaries are generated and may contain mistakes; the official description above is the record.
