{"answers":{"affected":"3 open source packages ship an affected version, including github.com/agnivade/easy-scrypt. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-125055 in the wild and no public exploit code.","fix":"Upgrade github.com/agnivade/easy-scrypt to 1.0.0 or later.","what":"CVE-2014-125055 is a low-severity vulnerability in agnivade easy-scrypt, published on 7 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-125055 and fix it if it is affected.\n\nWhat it is: CVE-2014-125055 is a low-severity vulnerability in agnivade easy-scrypt, published on 7 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-125055 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/agnivade/easy-scrypt (Go): affected all versions; fixed in 1.0.0\n- github.com/agnivade/easy-scrypt (Go): affected all versions; fixed in 1.0.0\n- github.com/agnivade/easy-scrypt (Go): affected all versions; fixed in 1.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-125055/ (Markdown: https://insights.sbomify.com/CVE-2014-125055/index.md)","id":"CVE-2014-125055","markdown":"https://insights.sbomify.com/CVE-2014-125055/index.md","name":"CVE-2014-125055","record":{"aliases":["GHSA-r894-5r7v-7rx3","GO-2023-1294"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Go scrypt library","requires_auth":"low_privilege","summary":"An attacker can exploit timing discrepancies in the VerifyPassphrase function to potentially recover sensitive password information.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"easy-script","vendor":"easy-script_project"}],"cvss":{"score":2.6,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-208","name":"Observable Timing Discrepancy"}],"description":"A vulnerability, which was classified as problematic, was found in agnivade easy-scrypt. Affected is the function VerifyPassphrase of the file scrypt.go. The manipulation leads to observable timing discrepancy. The complexity of an attack is rather high. The exploitability is told to be difficult. Upgrading to version 1.0.0 is able to address this issue. The name of the patch is 477c10cf3b144ddf96526aa09f5fdea613f21812. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217596.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"agnivade easy-scrypt scrypt.go VerifyPassphrase timing discrepancy","id":"CVE-2014-125055","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"information_disclosure","year":"2014"},"n_packages":3,"n_references":4,"next":{"headline":"Pylons horus services.py timing discrepancy","id":"CVE-2014-125056"},"packages":[{"ecosystem":"Go","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"github.com/agnivade/easy-scrypt","purl":null,"source":"GHSA-r894-5r7v-7rx3"},{"ecosystem":"Go","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"github.com/agnivade/easy-scrypt","purl":"pkg:golang/github.com/agnivade/easy-scrypt","source":"GHSA-r894-5r7v-7rx3"},{"ecosystem":"Go","fixed":["1.0.0"],"introduced":["0"],"last_affected":[],"package":"github.com/agnivade/easy-scrypt","purl":"pkg:golang/github.com/agnivade/easy-scrypt","source":"GO-2023-1294"}],"prev":{"headline":"koroket RedditOnRails Vote access control","id":"CVE-2014-125054"},"products":["easy-scrypt"],"published":"2023-01-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["agnivade"]},"summary":"An attacker can exploit timing discrepancies in the VerifyPassphrase function to potentially recover sensitive password information.","url":"https://insights.sbomify.com/CVE-2014-125055/"}