# CVE-2014-125055: agnivade easy-scrypt scrypt.go VerifyPassphrase timing discrepancy

> An attacker can exploit timing discrepancies in the VerifyPassphrase function to potentially recover sensitive password information.

- **Severity:** Low 2.6 (`CVSS:3.1/AV:A/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jan 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-r894-5r7v-7rx3, GO-2023-1294

## What is CVE-2014-125055?

CVE-2014-125055 is a low-severity vulnerability in agnivade easy-scrypt, published on 7 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability, which was classified as problematic, was found in agnivade easy-scrypt. Affected is the function VerifyPassphrase of the file scrypt.go. The manipulation leads to observable timing discrepancy. The complexity of an attack is rather high. The exploitability is told to be difficult. Upgrading to version 1.0.0 is able to address this issue. The name of the patch is 477c10cf3b144ddf96526aa09f5fdea613f21812. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217596.

Weakness: CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2014-125055?

3 open source packages ship an affected version, including github.com/agnivade/easy-scrypt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/agnivade/easy-scrypt` | Go | All versions | 1.0.0 |
| `github.com/agnivade/easy-scrypt` | Go | All versions | 1.0.0 |
| `github.com/agnivade/easy-scrypt` | Go | All versions | 1.0.0 |

Products: Easy-Script Project Easy-Script.

## How do I fix CVE-2014-125055?

Upgrade github.com/agnivade/easy-scrypt to 1.0.0 or later.

## Is CVE-2014-125055 being exploited?

There is no known exploitation of CVE-2014-125055 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-125055 and fix it if it is affected.

What it is: CVE-2014-125055 is a low-severity vulnerability in agnivade easy-scrypt, published on 7 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-125055 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/agnivade/easy-scrypt (Go): affected all versions; fixed in 1.0.0
- github.com/agnivade/easy-scrypt (Go): affected all versions; fixed in 1.0.0
- github.com/agnivade/easy-scrypt (Go): affected all versions; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-125055/ (Markdown: https://insights.sbomify.com/CVE-2014-125055/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-125055
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-125055
- OSV: https://osv.dev/vulnerability/CVE-2014-125055

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-125055/
Summaries are generated and may contain mistakes; the official description above is the record.
