{"answers":{"affected":"2 open source packages ship an affected version, including com.jamesmurty.utils:java-xmlbuilder. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-125087 in the wild and no public exploit code.","fix":"Upgrade com.jamesmurty.utils:java-xmlbuilder to 1.2 or later.","what":"CVE-2014-125087 is a medium-severity vulnerability in java-xmlbuilder, published on 19 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-125087 and fix it if it is affected.\n\nWhat it is: CVE-2014-125087 is a medium-severity vulnerability in java-xmlbuilder, published on 19 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-125087 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.jamesmurty.utils:java-xmlbuilder (Maven): affected all versions; fixed in 1.2\n- com.jamesmurty.utils:java-xmlbuilder (Maven): affected all versions; fixed in 1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-125087/ (Markdown: https://insights.sbomify.com/CVE-2014-125087/index.md)","id":"CVE-2014-125087","markdown":"https://insights.sbomify.com/CVE-2014-125087/index.md","name":"CVE-2014-125087","record":{"aliases":["GHSA-3vrc-rrpw-r5pw","UBUNTU-CVE-2014-125087"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Java XML builder library","requires_auth":"low_privilege","summary":"Attackers can exploit XML external entity references in java-xmlbuilder to read sensitive data or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"java-xmlbuilder","vendor":"java-xmlbuilder_project"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"A vulnerability was found in java-xmlbuilder up to 1.1. It has been rated as problematic. Affected by this issue is some unknown functionality. The manipulation leads to xml external entity reference. Upgrading to version 1.2 is able to address this issue. The name of the patch is e6fddca201790abab4f2c274341c0bb8835c3e73. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-221480.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"java-xmlbuilder xml external entity reference","id":"CVE-2014-125087","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2014"},"n_packages":2,"n_references":6,"next":{"headline":"qt-users-jp silk header.qml cross site scripting","id":"CVE-2014-125088"},"packages":[{"ecosystem":"Maven","fixed":["1.2"],"introduced":["0"],"last_affected":[],"package":"com.jamesmurty.utils:java-xmlbuilder","purl":null,"source":"GHSA-3vrc-rrpw-r5pw"},{"ecosystem":"Maven","fixed":["1.2"],"introduced":["0"],"last_affected":[],"package":"com.jamesmurty.utils:java-xmlbuilder","purl":"pkg:maven/com.jamesmurty.utils/java-xmlbuilder","source":"GHSA-3vrc-rrpw-r5pw"}],"prev":{"headline":"Gimmie Plugin trigger_login.php sql injection","id":"CVE-2014-125086"},"products":["java-xmlbuilder"],"published":"2023-02-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-02-13","vendors":["n/a"]},"summary":"Attackers can exploit XML external entity references in java-xmlbuilder to read sensitive data or cause denial of service.","url":"https://insights.sbomify.com/CVE-2014-125087/"}