# CVE-2014-125087: java-xmlbuilder xml external entity reference

> Attackers can exploit XML external entity references in java-xmlbuilder to read sensitive data or cause denial of service.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-3vrc-rrpw-r5pw, UBUNTU-CVE-2014-125087

## What is CVE-2014-125087?

CVE-2014-125087 is a medium-severity vulnerability in java-xmlbuilder, published on 19 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in java-xmlbuilder up to 1.1. It has been rated as problematic. Affected by this issue is some unknown functionality. The manipulation leads to xml external entity reference. Upgrading to version 1.2 is able to address this issue. The name of the patch is e6fddca201790abab4f2c274341c0bb8835c3e73. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-221480.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2014-125087?

2 open source packages ship an affected version, including com.jamesmurty.utils:java-xmlbuilder. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.jamesmurty.utils:java-xmlbuilder` | Maven | All versions | 1.2 |
| `com.jamesmurty.utils:java-xmlbuilder` | Maven | All versions | 1.2 |

Products: Java-Xmlbuilder Project Java-Xmlbuilder.

## How do I fix CVE-2014-125087?

Upgrade com.jamesmurty.utils:java-xmlbuilder to 1.2 or later.

## Is CVE-2014-125087 being exploited?

There is no known exploitation of CVE-2014-125087 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-125087 and fix it if it is affected.

What it is: CVE-2014-125087 is a medium-severity vulnerability in java-xmlbuilder, published on 19 Feb 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-125087 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.jamesmurty.utils:java-xmlbuilder (Maven): affected all versions; fixed in 1.2
- com.jamesmurty.utils:java-xmlbuilder (Maven): affected all versions; fixed in 1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-125087/ (Markdown: https://insights.sbomify.com/CVE-2014-125087/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-125087
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-125087
- OSV: https://osv.dev/vulnerability/CVE-2014-125087

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-125087/
Summaries are generated and may contain mistakes; the official description above is the record.
