CVE-2014-125092 MaxButtons Plugin maxbuttons-button.php maxbuttons_strip_px cross site scripting

Low 3.5 Published Updated

A cross-site scripting vulnerability in the MaxButtons WordPress plugin allows remote attackers to inject malicious scripts via the button_id argument.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2014-125092?

CVE-2014-125092 is a low-severity cross-site scripting vulnerability in MaxButtons Plugin, published on 5 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in MaxButtons Plugin up to 1.26.0 on WordPress and classified as problematic. This issue affects the function maxbuttons_strip_px of the file includes/maxbuttons-button.php. The manipulation of the argument button_id leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 1.26.1 is able to address this issue. The patch is named e74564c9e3b7429808e317f4916bd1c26ef0b806. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-222323.

Weakness: CWE-79

Which versions are affected by CVE-2014-125092?

It affects 1 product.

Products include Maxfoundry Maxbuttons.

How do I fix CVE-2014-125092?

No fix has been published for CVE-2014-125092 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2014-125092 being exploited?

There is no known exploitation of CVE-2014-125092 in the wild and no public exploit code.

Sources

Also known as GHSA-7mh4-2xvc-88jh.

Is CVE-2014-125092 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free