{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-125092 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2014-125092 yet. Limit exposure of the affected software until one is available.","what":"CVE-2014-125092 is a low-severity cross-site scripting vulnerability in MaxButtons Plugin, published on 5 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-125092 and fix it if it is affected.\n\nWhat it is: CVE-2014-125092 is a low-severity cross-site scripting vulnerability in MaxButtons Plugin, published on 5 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-125092 in the wild and no public exploit code.\n\nAffected product: MaxButtons Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-125092/ (Markdown: https://insights.sbomify.com/CVE-2014-125092/index.md)","id":"CVE-2014-125092","markdown":"https://insights.sbomify.com/CVE-2014-125092/index.md","name":"CVE-2014-125092","record":{"aliases":["GHSA-7mh4-2xvc-88jh"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"A cross-site scripting vulnerability in the MaxButtons WordPress plugin allows remote attackers to inject malicious scripts via the button_id argument.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"maxbuttons","vendor":"maxfoundry"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in MaxButtons Plugin up to 1.26.0 on WordPress and classified as problematic. This issue affects the function maxbuttons_strip_px of the file includes/maxbuttons-button.php. The manipulation of the argument button_id leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 1.26.1 is able to address this issue. The patch is named e74564c9e3b7429808e317f4916bd1c26ef0b806. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-222323.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"MaxButtons Plugin maxbuttons-button.php maxbuttons_strip_px cross site scripting","id":"CVE-2014-125092","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2014"},"n_packages":0,"n_references":4,"next":{"headline":"Ad Blocking Detector Plugin ad-blocking-detector.php information disclosure","id":"CVE-2014-125093"},"packages":[],"prev":{"headline":"codepeople cp-polls Plugin cp-admin-int-message-list.inc.php sql injection","id":"CVE-2014-125091"},"products":["MaxButtons Plugin"],"published":"2023-03-05","related":[{"cvss_score":6.5,"headline":"WordPress MaxButtons Plugin \u003c= 9.5.3 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-36503","kev_date_added":null,"published":"2023-07-25"},{"cvss_score":6.4,"headline":"WordPress Button Plugin MaxButtons \u003c= 9.7.6 - Authenticated(Contributor+) Stored Cross-Site Scripting via shortcode","id":"CVE-2023-7029","kev_date_added":null,"published":"2024-02-05"},{"cvss_score":5.4,"headline":"WordPress Button Plugin MaxButtons \u003c 9.7.8 - Editor+ Stored XSS","id":"CVE-2024-3026","kev_date_added":null,"published":"2024-07-13"},{"cvss_score":5.3,"headline":"WordPress Button Plugin MaxButtons \u003c= 9.7.8 - Full Path Disclosure","id":"CVE-2024-6499","kev_date_added":null,"published":"2024-08-24"},{"cvss_score":4.8,"headline":"MaxButtons \u003c 9.8.1 - Admin+ Stored XSS via Button Width","id":"CVE-2024-10555","kev_date_added":null,"published":"2024-12-20"},{"cvss_score":4.7,"headline":"MaxButtons \u003c 9.8.1 - Admin+ Stored XSS via Text Color","id":"CVE-2024-8968","kev_date_added":null,"published":"2024-12-20"},{"cvss_score":4.4,"headline":"WordPress Button Plugin MaxButtons \u003c= 9.7.4 - Authenticated (Administrator+) Stored Cross-Site Scripting","id":"CVE-2023-6594","kev_date_added":null,"published":"2024-01-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-05","vendors":["n/a"]},"summary":"A cross-site scripting vulnerability in the MaxButtons WordPress plugin allows remote attackers to inject malicious scripts via the button_id argument.","url":"https://insights.sbomify.com/CVE-2014-125092/"}