{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-125093 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2014-125093 yet. Limit exposure of the affected software until one is available.","what":"CVE-2014-125093 is a medium-severity vulnerability in Ad Blocking Detector Plugin, published on 10 Mar 2023."},"fix_prompt":"Check this codebase for CVE-2014-125093 and fix it if it is affected.\n\nWhat it is: CVE-2014-125093 is a medium-severity vulnerability in Ad Blocking Detector Plugin, published on 10 Mar 2023. \nExploitation: There is no known exploitation of CVE-2014-125093 in the wild and no public exploit code.\n\nAffected product: Ad Blocking Detector Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-125093/ (Markdown: https://insights.sbomify.com/CVE-2014-125093/index.md)","id":"CVE-2014-125093","markdown":"https://insights.sbomify.com/CVE-2014-125093/index.md","name":"CVE-2014-125093","record":{"aliases":["GHSA-m6f6-7crg-x4v7"],"analysis":null,"analysis_generated_by":null,"assigner":"VulDB","cpe":[{"product":"ad_blocking_detector","vendor":"getadmiral"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"A vulnerability has been found in Ad Blocking Detector Plugin up to 1.2.1 on WordPress and classified as problematic. This vulnerability affects unknown code of the file ad-blocking-detector.php. The manipulation leads to information disclosure. The attack can be initiated remotely. Upgrading to version 1.2.2 is able to address this issue. The patch is identified as 3312b9cd79e5710d1e282fc9216a4e5ab31b3d94. It is recommended to upgrade the affected component. VDB-222610 is the identifier assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Ad Blocking Detector Plugin ad-blocking-detector.php information disclosure","id":"CVE-2014-125093","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2014"},"n_packages":0,"n_references":4,"next":{"headline":"phpMiniAdmin cross site scripting","id":"CVE-2014-125094"},"packages":[],"prev":{"headline":"MaxButtons Plugin maxbuttons-button.php maxbuttons_strip_px cross site scripting","id":"CVE-2014-125092"},"products":["Ad Blocking Detector Plugin"],"published":"2023-03-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2014-125093/"}