CVE-2014-125094 phpMiniAdmin cross site scripting

Low 3.5 Published Updated

Remote attackers can execute arbitrary scripts in the context of other users via a cross-site scripting vulnerability in phpMiniAdmin.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2014-125094?

CVE-2014-125094 is a low-severity cross-site scripting vulnerability in phpMiniAdmin, published on 6 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability classified as problematic was found in phpMiniAdmin up to 1.8.120510. Affected by this vulnerability is an unknown functionality. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.9.140405 is able to address this issue. It is recommended to upgrade the affected component. The identifier VDB-225001 was assigned to this vulnerability.

Weakness: CWE-79

Which versions are affected by CVE-2014-125094?

It affects 1 product.

Products include Phpminiadmin Project Phpminiadmin.

How do I fix CVE-2014-125094?

No fix has been published for CVE-2014-125094 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2014-125094 being exploited?

There is no known exploitation of CVE-2014-125094 in the wild and no public exploit code.

Sources

Also known as GHSA-922m-qj78-jxxc.

Is CVE-2014-125094 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free