{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-125098 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2014-125098 yet. Limit exposure of the affected software until one is available.","what":"CVE-2014-125098 is a medium-severity cross-site scripting vulnerability in Dart http_server, published on 10 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-125098 and fix it if it is affected.\n\nWhat it is: CVE-2014-125098 is a medium-severity cross-site scripting vulnerability in Dart http_server, published on 10 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-125098 in the wild and no public exploit code.\n\nAffected product: Dart http_server. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-125098/ (Markdown: https://insights.sbomify.com/CVE-2014-125098/index.md)","id":"CVE-2014-125098","markdown":"https://insights.sbomify.com/CVE-2014-125098/index.md","name":"CVE-2014-125098","record":{"aliases":["GHSA-3vf7-gh27-gx55"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Dart http_server library","requires_auth":"none","summary":"Remote attackers can execute arbitrary scripts via cross-site scripting in the Dart http_server library's directory listing handler.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"http_server","vendor":"dart"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in Dart http_server up to 0.9.5 and classified as problematic. Affected by this issue is the function VirtualDirectory of the file lib/src/virtual_directory.dart of the component Directory Listing Handler. The manipulation of the argument request.uri.path leads to cross site scripting. The attack may be launched remotely. Upgrading to version 0.9.6 is able to address this issue. The name of the patch is 27c1cbd8125bb0369e675eb72e48218496e48ffb. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-225356.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Dart http_server Directory Listing virtual_directory.dart VirtualDirectory cross site scripting","id":"CVE-2014-125098","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2014"},"n_packages":0,"n_references":5,"next":{"headline":"I Recommend This Plugin dot-irecommendthis.php sql injection","id":"CVE-2014-125099"},"packages":[],"prev":{"headline":"BestWebSoft Facebook Like Button facebook-button-plugin.php fcbkbttn_settings_page cross site scripting","id":"CVE-2014-125097"},"products":["http_server"],"published":"2023-04-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-07","vendors":["Dart"]},"summary":"Remote attackers can execute arbitrary scripts via cross-site scripting in the Dart http_server library's directory listing handler.","url":"https://insights.sbomify.com/CVE-2014-125098/"}