# CVE-2014-125098: Dart http_server Directory Listing virtual_directory.dart VirtualDirectory cross site scripting

> Remote attackers can execute arbitrary scripts via cross-site scripting in the Dart http_server library's directory listing handler.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 10 Apr 2023
- **Updated:** 7 Feb 2025
- **Also known as:** GHSA-3vf7-gh27-gx55

## What is CVE-2014-125098?

CVE-2014-125098 is a medium-severity cross-site scripting vulnerability in Dart http_server, published on 10 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in Dart http_server up to 0.9.5 and classified as problematic. Affected by this issue is the function VirtualDirectory of the file lib/src/virtual_directory.dart of the component Directory Listing Handler. The manipulation of the argument request.uri.path leads to cross site scripting. The attack may be launched remotely. Upgrading to version 0.9.6 is able to address this issue. The name of the patch is 27c1cbd8125bb0369e675eb72e48218496e48ffb. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-225356.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2014-125098?

It affects 1 product.


Products: Dart Http Server.

## How do I fix CVE-2014-125098?

No fix has been published for CVE-2014-125098 yet. Limit exposure of the affected software until one is available.

## Is CVE-2014-125098 being exploited?

There is no known exploitation of CVE-2014-125098 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-125098 and fix it if it is affected.

What it is: CVE-2014-125098 is a medium-severity cross-site scripting vulnerability in Dart http_server, published on 10 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-125098 in the wild and no public exploit code.

Affected product: Dart http_server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-125098/ (Markdown: https://insights.sbomify.com/CVE-2014-125098/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-125098
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-125098
- OSV: https://osv.dev/vulnerability/CVE-2014-125098

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-125098/
Summaries are generated and may contain mistakes; the official description above is the record.
