CVE-2014-125099 I Recommend This Plugin dot-irecommendthis.php sql injection

Medium 6.3 Published Updated

Remote attackers can exploit SQL injection in the I Recommend This WordPress plugin to read or modify database contents.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2014-125099?

CVE-2014-125099 is a medium-severity SQL injection vulnerability in I Recommend This Plugin, published on 20 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability has been found in I Recommend This Plugin up to 3.7.2 on WordPress and classified as critical. Affected by this vulnerability is an unknown functionality of the file dot-irecommendthis.php. The manipulation leads to sql injection. The attack can be launched remotely. Upgrading to version 3.7.3 is able to address this issue. The identifier of the patch is 058b3ef5c7577bf557557904a53ecc8599b13649. It is recommended to upgrade the affected component. The identifier VDB-226309 was assigned to this vulnerability.

Weakness: CWE-89

Which versions are affected by CVE-2014-125099?

It affects 1 product.

Products include Themeist I Recommend This.

How do I fix CVE-2014-125099?

No fix has been published for CVE-2014-125099 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2014-125099 being exploited?

There is no known exploitation of CVE-2014-125099 in the wild and no public exploit code.

Sources

Also known as GHSA-f6j6-4qcx-fq7v.

Is CVE-2014-125099 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free