{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-125099 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2014-125099 yet. Limit exposure of the affected software until one is available.","what":"CVE-2014-125099 is a medium-severity SQL injection vulnerability in I Recommend This Plugin, published on 20 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-125099 and fix it if it is affected.\n\nWhat it is: CVE-2014-125099 is a medium-severity SQL injection vulnerability in I Recommend This Plugin, published on 20 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-125099 in the wild and no public exploit code.\n\nAffected product: I Recommend This Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-125099/ (Markdown: https://insights.sbomify.com/CVE-2014-125099/index.md)","id":"CVE-2014-125099","markdown":"https://insights.sbomify.com/CVE-2014-125099/index.md","name":"CVE-2014-125099","record":{"aliases":["GHSA-f6j6-4qcx-fq7v"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Remote attackers can exploit SQL injection in the I Recommend This WordPress plugin to read or modify database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"i_recommend_this","vendor":"themeist"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"A vulnerability has been found in I Recommend This Plugin up to 3.7.2 on WordPress and classified as critical. Affected by this vulnerability is an unknown functionality of the file dot-irecommendthis.php. The manipulation leads to sql injection. The attack can be launched remotely. Upgrading to version 3.7.3 is able to address this issue. The identifier of the patch is 058b3ef5c7577bf557557904a53ecc8599b13649. It is recommended to upgrade the affected component. The identifier VDB-226309 was assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"I Recommend This Plugin dot-irecommendthis.php sql injection","id":"CVE-2014-125099","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"sql_injection","year":"2014"},"n_packages":0,"n_references":4,"next":{"headline":"BestWebSoft Job Board Plugin cross site scripting","id":"CVE-2014-125100"},"packages":[],"prev":{"headline":"Dart http_server Directory Listing virtual_directory.dart VirtualDirectory cross site scripting","id":"CVE-2014-125098"},"products":["I Recommend This Plugin"],"published":"2023-04-20","related":[{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2014-10376","kev_date_added":null,"published":"2019-08-16"},{"cvss_score":5.9,"headline":"WordPress I Recommend This Plugin \u003c= 3.8.3 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-23673","kev_date_added":null,"published":"2023-05-16"},{"cvss_score":4.3,"headline":"WordPress I Recommend This Plugin \u003c= 3.9.0 is vulnerable to Cross Site Request Forgery (CSRF)","id":"CVE-2023-28696","kev_date_added":null,"published":"2023-11-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can exploit SQL injection in the I Recommend This WordPress plugin to read or modify database contents.","url":"https://insights.sbomify.com/CVE-2014-125099/"}