# CVE-2014-125099: I Recommend This Plugin dot-irecommendthis.php sql injection

> Remote attackers can exploit SQL injection in the I Recommend This WordPress plugin to read or modify database contents.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 20 Apr 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-f6j6-4qcx-fq7v

## What is CVE-2014-125099?

CVE-2014-125099 is a medium-severity SQL injection vulnerability in I Recommend This Plugin, published on 20 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability has been found in I Recommend This Plugin up to 3.7.2 on WordPress and classified as critical. Affected by this vulnerability is an unknown functionality of the file dot-irecommendthis.php. The manipulation leads to sql injection. The attack can be launched remotely. Upgrading to version 3.7.3 is able to address this issue. The identifier of the patch is 058b3ef5c7577bf557557904a53ecc8599b13649. It is recommended to upgrade the affected component. The identifier VDB-226309 was assigned to this vulnerability.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2014-125099?

It affects 1 product.


Products: Themeist I Recommend This.

## How do I fix CVE-2014-125099?

No fix has been published for CVE-2014-125099 yet. Limit exposure of the affected software until one is available.

## Is CVE-2014-125099 being exploited?

There is no known exploitation of CVE-2014-125099 in the wild and no public exploit code.

## Other vulnerabilities in I Recommend This Plugin

- [CVE-2014-10376](https://insights.sbomify.com/CVE-2014-10376/): SQL injection in n/a (critical 9.8)
- [CVE-2023-23673](https://insights.sbomify.com/CVE-2023-23673/): WordPress I Recommend This Plugin <= 3.8.3 is vulnerable to Cross Site Scripting (XSS) (medium 5.9)
- [CVE-2023-28696](https://insights.sbomify.com/CVE-2023-28696/): WordPress I Recommend This Plugin <= 3.9.0 is vulnerable to Cross Site Request Forgery (CSRF) (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-125099 and fix it if it is affected.

What it is: CVE-2014-125099 is a medium-severity SQL injection vulnerability in I Recommend This Plugin, published on 20 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-125099 in the wild and no public exploit code.

Affected product: I Recommend This Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-125099/ (Markdown: https://insights.sbomify.com/CVE-2014-125099/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-125099
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-125099
- OSV: https://osv.dev/vulnerability/CVE-2014-125099

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-125099/
Summaries are generated and may contain mistakes; the official description above is the record.
