{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-125103 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2014-125103 yet. Limit exposure of the affected software until one is available.","what":"CVE-2014-125103 is a low-severity cross-site scripting vulnerability in BestWebSoft Twitter Plugin, published on 31 May 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-125103 and fix it if it is affected.\n\nWhat it is: CVE-2014-125103 is a low-severity cross-site scripting vulnerability in BestWebSoft Twitter Plugin, published on 31 May 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-125103 in the wild and no public exploit code.\n\nAffected product: BestWebSoft Twitter Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-125103/ (Markdown: https://insights.sbomify.com/CVE-2014-125103/index.md)","id":"CVE-2014-125103","markdown":"https://insights.sbomify.com/CVE-2014-125103/index.md","name":"CVE-2014-125103","record":{"aliases":["GHSA-ppf9-f28m-8wvh"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"high_privilege","summary":"Remote attackers can inject malicious scripts via the Twitter plugin settings, potentially compromising user sessions and site integrity.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"twitter","vendor":"bestwebsoft"}],"cvss":{"score":2.4,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in BestWebSoft Twitter Plugin up to 1.3.2 on WordPress. It has been declared as problematic. Affected by this vulnerability is the function twttr_settings_page of the file twitter.php. The manipulation of the argument twttr_url_twitter/bws_license_key/bws_license_plugin leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.3.7 is able to address this issue. The patch is named e04d59ab578316ffeb204cf32dc71c0d0e1ff77c. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-230155.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"BestWebSoft Twitter Plugin twitter.php twttr_settings_page cross site scripting","id":"CVE-2014-125103","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2014"},"n_packages":0,"n_references":3,"next":{"headline":"VaultPress Plugin MailPoet Plugin class.vaultpress-hotfixes.php protect_aioseo_ajax unrestricted upload","id":"CVE-2014-125104"},"packages":[],"prev":{"headline":"Bestwebsoft Relevant Plugin Thumbnail information disclosure","id":"CVE-2014-125102"},"products":["Twitter Plugin"],"published":"2023-05-31","related":[{"cvss_score":4.3,"headline":"BestWebSoft Twitter Plugin Settings Page twitter.php twttr_settings_page cross-site request forgery","id":"CVE-2012-10015","kev_date_added":null,"published":"2023-05-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-05","vendors":["BestWebSoft"]},"summary":"Remote attackers can inject malicious scripts via the Twitter plugin settings, potentially compromising user sessions and site integrity.","url":"https://insights.sbomify.com/CVE-2014-125103/"}