# CVE-2014-125103: BestWebSoft Twitter Plugin twitter.php twttr_settings_page cross site scripting

> Remote attackers can inject malicious scripts via the Twitter plugin settings, potentially compromising user sessions and site integrity.

- **Severity:** Low 2.4 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 31 May 2023
- **Updated:** 5 Mar 2025
- **Also known as:** GHSA-ppf9-f28m-8wvh

## What is CVE-2014-125103?

CVE-2014-125103 is a low-severity cross-site scripting vulnerability in BestWebSoft Twitter Plugin, published on 31 May 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in BestWebSoft Twitter Plugin up to 1.3.2 on WordPress. It has been declared as problematic. Affected by this vulnerability is the function twttr_settings_page of the file twitter.php. The manipulation of the argument twttr_url_twitter/bws_license_key/bws_license_plugin leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.3.7 is able to address this issue. The patch is named e04d59ab578316ffeb204cf32dc71c0d0e1ff77c. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-230155.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2014-125103?

It affects 1 product.


Products: Bestwebsoft Twitter.

## How do I fix CVE-2014-125103?

No fix has been published for CVE-2014-125103 yet. Limit exposure of the affected software until one is available.

## Is CVE-2014-125103 being exploited?

There is no known exploitation of CVE-2014-125103 in the wild and no public exploit code.

## Other vulnerabilities in BestWebSoft Twitter Plugin

- [CVE-2012-10015](https://insights.sbomify.com/CVE-2012-10015/): BestWebSoft Twitter Plugin Settings Page twitter.php twttr_settings_page cross-site request forgery (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-125103 and fix it if it is affected.

What it is: CVE-2014-125103 is a low-severity cross-site scripting vulnerability in BestWebSoft Twitter Plugin, published on 31 May 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-125103 in the wild and no public exploit code.

Affected product: BestWebSoft Twitter Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-125103/ (Markdown: https://insights.sbomify.com/CVE-2014-125103/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-125103
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-125103
- OSV: https://osv.dev/vulnerability/CVE-2014-125103

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-125103/
Summaries are generated and may contain mistakes; the official description above is the record.
