CVE-2014-125104 VaultPress Plugin MailPoet Plugin class.vaultpress-hotfixes.php protect_aioseo_ajax unrestricted upload

Medium 6.3 Published Updated

An attacker with permissions can upload malicious files via the MailPoet plugin integration, potentially leading to remote code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2014-125104?

CVE-2014-125104 is a medium-severity vulnerability in VaultPress Plugin, published on 1 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability was found in VaultPress Plugin up to 1.6.0 on WordPress. It has been declared as critical. Affected by this vulnerability is the function protect_aioseo_ajax of the file class.vaultpress-hotfixes.php of the component MailPoet Plugin. The manipulation leads to unrestricted upload. The attack can be launched remotely. Upgrading to version 1.6.1 is able to address this issue. The patch is named e3b92b14edca6291c5f998d54c90cbe98a1fb0e3. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-230263.

Weakness: CWE-434

Which versions are affected by CVE-2014-125104?

It affects 1 product.

Products include Automattic Vaultpress.

How do I fix CVE-2014-125104?

No fix has been published for CVE-2014-125104 yet. Limit exposure of the affected software until one is available.

Is CVE-2014-125104 being exploited?

There is no known exploitation of CVE-2014-125104 in the wild and no public exploit code.

Sources

Also known as GHSA-rf67-fgh6-8jjv.

Is CVE-2014-125104 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free