{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-125104 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2014-125104 yet. Limit exposure of the affected software until one is available.","what":"CVE-2014-125104 is a medium-severity vulnerability in VaultPress Plugin, published on 1 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-125104 and fix it if it is affected.\n\nWhat it is: CVE-2014-125104 is a medium-severity vulnerability in VaultPress Plugin, published on 1 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-125104 in the wild and no public exploit code.\n\nAffected product: VaultPress Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-125104/ (Markdown: https://insights.sbomify.com/CVE-2014-125104/index.md)","id":"CVE-2014-125104","markdown":"https://insights.sbomify.com/CVE-2014-125104/index.md","name":"CVE-2014-125104","record":{"aliases":["GHSA-rf67-fgh6-8jjv"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"An attacker with permissions can upload malicious files via the MailPoet plugin integration, potentially leading to remote code execution.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"vaultpress","vendor":"automattic"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"A vulnerability was found in VaultPress Plugin up to 1.6.0 on WordPress. It has been declared as critical. Affected by this vulnerability is the function protect_aioseo_ajax of the file class.vaultpress-hotfixes.php of the component MailPoet Plugin. The manipulation leads to unrestricted upload. The attack can be launched remotely. Upgrading to version 1.6.1 is able to address this issue. The patch is named e3b92b14edca6291c5f998d54c90cbe98a1fb0e3. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-230263.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"VaultPress Plugin MailPoet Plugin class.vaultpress-hotfixes.php protect_aioseo_ajax unrestricted upload","id":"CVE-2014-125104","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"file_upload","year":"2014"},"n_packages":0,"n_references":4,"next":{"headline":"Broken Link Checker Plugin Settings Page core.php options_page cross site scripting","id":"CVE-2014-125105"},"packages":[],"prev":{"headline":"BestWebSoft Twitter Plugin twitter.php twttr_settings_page cross site scripting","id":"CVE-2014-125103"},"products":["VaultPress Plugin"],"published":"2023-06-01","related":[{"cvss_score":6.3,"headline":"VaultPress Plugin code injection","id":"CVE-2017-20086","kev_date_added":null,"published":"2022-06-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-05","vendors":["n/a"]},"summary":"An attacker with permissions can upload malicious files via the MailPoet plugin integration, potentially leading to remote code execution.","url":"https://insights.sbomify.com/CVE-2014-125104/"}