CVE-2014-125105 Broken Link Checker Plugin Settings Page core.php options_page cross site scripting
Remote attackers can inject malicious scripts via the settings page, potentially leading to code execution in the WordPress environment.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2014-125105?
CVE-2014-125105 is a low-severity cross-site scripting vulnerability in Broken Link Checker Plugin, published on 5 Jun 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
A vulnerability was found in Broken Link Checker Plugin up to 1.10.1 on WordPress. It has been declared as problematic. Affected by this vulnerability is the function options_page of the file core/core.php of the component Settings Page. The manipulation of the argument exclusion_list/blc_custom_fields leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.10.2 is able to address this issue. The patch is named 90615fe9b0b6f9e6fb254d503c302e53a202e561. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-230659.
Weakness: CWE-79
Which versions are affected by CVE-2014-125105?
It affects 1 product.
Products include Managewp Broken Link Checker.
How do I fix CVE-2014-125105?
No fix has been published for CVE-2014-125105 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2014-125105 being exploited?
There is no known exploitation of CVE-2014-125105 in the wild and no public exploit code.
Other vulnerabilities in Broken Link Checker Plugin
- CVE-2023-23737 WordPress MainWP Broken Links Checker Extension Plugin <= 4.0 is vulnerable to SQL Injection
- CVE-2022-2438 Broken Link Checker <= 1.11.16 - Authenticated (Admin+) PHAR Deserialization
- CVE-2019-16521 Cross-site scripting in n/a
- CVE-2019-17207 Cross-site scripting in n/a
- CVE-2022-3922 Broken Link Checker < 1.11.20 - Admin+ Cross-Site Scripting
Sources
Also known as GHSA-5crm-f6x3-hr2w.