# CVE-2014-125105: Broken Link Checker Plugin Settings Page core.php options_page cross site scripting

> Remote attackers can inject malicious scripts via the settings page, potentially leading to code execution in the WordPress environment.

- **Severity:** Low 2.4 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 5 Jun 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-5crm-f6x3-hr2w

## What is CVE-2014-125105?

CVE-2014-125105 is a low-severity cross-site scripting vulnerability in Broken Link Checker Plugin, published on 5 Jun 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in Broken Link Checker Plugin up to 1.10.1 on WordPress. It has been declared as problematic. Affected by this vulnerability is the function options_page of the file core/core.php of the component Settings Page. The manipulation of the argument exclusion_list/blc_custom_fields leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.10.2 is able to address this issue. The patch is named 90615fe9b0b6f9e6fb254d503c302e53a202e561. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-230659.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2014-125105?

It affects 1 product.


Products: Managewp Broken Link Checker.

## How do I fix CVE-2014-125105?

No fix has been published for CVE-2014-125105 yet. Limit exposure of the affected software until one is available.

## Is CVE-2014-125105 being exploited?

There is no known exploitation of CVE-2014-125105 in the wild and no public exploit code.

## Other vulnerabilities in Broken Link Checker Plugin

- [CVE-2023-23737](https://insights.sbomify.com/CVE-2023-23737/): WordPress MainWP Broken Links Checker Extension Plugin <= 4.0 is vulnerable to SQL Injection (critical 9.3)
- [CVE-2022-2438](https://insights.sbomify.com/CVE-2022-2438/): Broken Link Checker <= 1.11.16 - Authenticated (Admin+) PHAR Deserialization (high 7.2)
- [CVE-2019-16521](https://insights.sbomify.com/CVE-2019-16521/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2019-17207](https://insights.sbomify.com/CVE-2019-17207/): Cross-site scripting in n/a (medium 5.4)
- [CVE-2022-3922](https://insights.sbomify.com/CVE-2022-3922/): Broken Link Checker < 1.11.20 - Admin+ Cross-Site Scripting (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-125105 and fix it if it is affected.

What it is: CVE-2014-125105 is a low-severity cross-site scripting vulnerability in Broken Link Checker Plugin, published on 5 Jun 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-125105 in the wild and no public exploit code.

Affected product: Broken Link Checker Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-125105/ (Markdown: https://insights.sbomify.com/CVE-2014-125105/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-125105
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-125105
- OSV: https://osv.dev/vulnerability/CVE-2014-125105

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-125105/
Summaries are generated and may contain mistakes; the official description above is the record.
