{"answers":{"affected":"2 open source packages ship an affected version, including corveda/phpsandbox. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-125107 in the wild and no public exploit code.","fix":"Upgrade corveda/phpsandbox to 1.3.5 or later.","what":"CVE-2014-125107 is a medium-severity vulnerability in Corveda PHPSandbox, published on 19 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-125107 and fix it if it is affected.\n\nWhat it is: CVE-2014-125107 is a medium-severity vulnerability in Corveda PHPSandbox, published on 19 Dec 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-125107 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- corveda/phpsandbox (Packagist): affected all versions; fixed in 1.3.5\n- corveda/phpsandbox (Packagist): affected all versions; fixed in 1.3.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-125107/ (Markdown: https://insights.sbomify.com/CVE-2014-125107/index.md)","id":"CVE-2014-125107","markdown":"https://insights.sbomify.com/CVE-2014-125107/index.md","name":"CVE-2014-125107","record":{"aliases":["GHSA-625p-jwcp-r2r5"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP sandbox library","requires_auth":"low_privilege","summary":"Attackers can bypass the string protection mechanism in Corveda PHPSandbox, potentially executing restricted code.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"phpsandbox","vendor":"corveda"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-693","name":"Protection Mechanism Failure"}],"description":"A vulnerability was found in Corveda PHPSandbox 1.3.4 and classified as critical. Affected by this issue is some unknown functionality of the component String Handler. The manipulation leads to protection mechanism failure. The attack may be launched remotely. Upgrading to version 1.3.5 is able to address this issue. The patch is identified as 48fde5ffa4d76014bad260a3cbab7ada3744a4cc. It is recommended to upgrade the affected component. VDB-248270 is the identifier assigned to this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Corveda PHPSandbox String protection mechanism","id":"CVE-2014-125107","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"security_feature_bypass","year":"2014"},"n_packages":2,"n_references":4,"next":{"headline":"w3c online-spellchecker-py spellchecker cross site scripting","id":"CVE-2014-125108"},"packages":[{"ecosystem":"Packagist","fixed":["1.3.5"],"introduced":["0"],"last_affected":[],"package":"corveda/phpsandbox","purl":null,"source":"GHSA-625p-jwcp-r2r5"},{"ecosystem":"Packagist","fixed":["1.3.5"],"introduced":["0"],"last_affected":[],"package":"corveda/phpsandbox","purl":"pkg:composer/corveda/phpsandbox","source":"GHSA-625p-jwcp-r2r5"}],"prev":{"headline":"Integer overflow in n/a","id":"CVE-2014-125106"},"products":["PHPSandbox"],"published":"2023-12-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["Corveda"]},"summary":"Attackers can bypass the string protection mechanism in Corveda PHPSandbox, potentially executing restricted code.","url":"https://insights.sbomify.com/CVE-2014-125107/"}