CVE-2014-125109 BestWebSoft Portfolio Plugin bws_menu.php bws_add_menu_render cross site scripting

Low 3.5 Published Updated

A remote attacker can inject malicious scripts via the email argument in the BestWebSoft Portfolio Plugin, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2014-125109?

CVE-2014-125109 is a low-severity cross-site scripting vulnerability in BestWebSoft Portfolio Plugin, published on 26 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in BestWebSoft Portfolio Plugin up to 2.27. It has been declared as problematic. This vulnerability affects the function bws_add_menu_render of the file bws_menu/bws_menu.php. The manipulation of the argument bwsmn_form_email leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 2.28 is able to address this issue. The name of the patch is d2ede580474665af56ff262a05783fbabe4529b8. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-248956.

Weakness: CWE-79

Which versions are affected by CVE-2014-125109?

It affects 1 product.

Products include Bestwebsoft Portfolio.

How do I fix CVE-2014-125109?

No fix has been published for CVE-2014-125109 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2014-125109 being exploited?

There is no known exploitation of CVE-2014-125109 in the wild and no public exploit code.

Sources

Also known as GHSA-q76p-m6h8-c3rv.

Is CVE-2014-125109 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free