{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-125109 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2014-125109 yet. Limit exposure of the affected software until one is available.","what":"CVE-2014-125109 is a low-severity cross-site scripting vulnerability in BestWebSoft Portfolio Plugin, published on 26 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-125109 and fix it if it is affected.\n\nWhat it is: CVE-2014-125109 is a low-severity cross-site scripting vulnerability in BestWebSoft Portfolio Plugin, published on 26 Dec 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-125109 in the wild and no public exploit code.\n\nAffected product: BestWebSoft Portfolio Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-125109/ (Markdown: https://insights.sbomify.com/CVE-2014-125109/index.md)","id":"CVE-2014-125109","markdown":"https://insights.sbomify.com/CVE-2014-125109/index.md","name":"CVE-2014-125109","record":{"aliases":["GHSA-q76p-m6h8-c3rv"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"A remote attacker can inject malicious scripts via the email argument in the BestWebSoft Portfolio Plugin, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"portfolio","vendor":"bestwebsoft"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in BestWebSoft Portfolio Plugin up to 2.27. It has been declared as problematic. This vulnerability affects the function bws_add_menu_render of the file bws_menu/bws_menu.php. The manipulation of the argument bwsmn_form_email leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 2.28 is able to address this issue. The name of the patch is d2ede580474665af56ff262a05783fbabe4529b8. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-248956.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"BestWebSoft Portfolio Plugin bws_menu.php bws_add_menu_render cross site scripting","id":"CVE-2014-125109","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2014"},"n_packages":0,"n_references":3,"next":{"headline":"wp-file-upload Plugin wfu_ajaxactions.php wfu_ajax_action_callback cross site scripting","id":"CVE-2014-125110"},"packages":[],"prev":{"headline":"w3c online-spellchecker-py spellchecker cross site scripting","id":"CVE-2014-125108"},"products":["Portfolio Plugin"],"published":"2023-12-26","related":[{"cvss_score":4.3,"headline":"BestWebSoft Portfolio Plugin cross-site request forgery","id":"CVE-2012-10017","kev_date_added":null,"published":"2023-12-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["BestWebSoft"]},"summary":"A remote attacker can inject malicious scripts via the email argument in the BestWebSoft Portfolio Plugin, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2014-125109/"}