{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2014-125110 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2014-125110 yet. Limit exposure of the affected software until one is available.","what":"CVE-2014-125110 is a low-severity cross-site scripting vulnerability in wp-file-upload Plugin, published on 31 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-125110 and fix it if it is affected.\n\nWhat it is: CVE-2014-125110 is a low-severity cross-site scripting vulnerability in wp-file-upload Plugin, published on 31 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-125110 in the wild and no public exploit code.\n\nAffected product: wp-file-upload Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-125110/ (Markdown: https://insights.sbomify.com/CVE-2014-125110/index.md)","id":"CVE-2014-125110","markdown":"https://insights.sbomify.com/CVE-2014-125110/index.md","name":"CVE-2014-125110","record":{"aliases":["GHSA-8x2p-m64p-q55q"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"A cross-site scripting vulnerability in the wp-file-upload WordPress plugin allows remote attackers to inject malicious scripts via the wfu_ajax_action_callback function.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability has been found in wp-file-upload Plugin up to 2.4.3 on WordPress and classified as problematic. Affected by this vulnerability is the function wfu_ajax_action_callback of the file lib/wfu_ajaxactions.php. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 2.4.4 is able to address this issue. The identifier of the patch is c846327df030a0a97da036a2f07c769ab9284ddb. It is recommended to upgrade the affected component. The identifier VDB-258781 was assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"wp-file-upload Plugin wfu_ajaxactions.php wfu_ajax_action_callback cross site scripting","id":"CVE-2014-125110","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2014"},"n_packages":0,"n_references":4,"next":{"headline":"namithjawahar Wp-Insert cross site scripting","id":"CVE-2014-125111"},"packages":[],"prev":{"headline":"BestWebSoft Portfolio Plugin bws_menu.php bws_add_menu_render cross site scripting","id":"CVE-2014-125109"},"products":["wp-file-upload Plugin"],"published":"2024-03-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"A cross-site scripting vulnerability in the wp-file-upload WordPress plugin allows remote attackers to inject malicious scripts via the wfu_ajax_action_callback function.","url":"https://insights.sbomify.com/CVE-2014-125110/"}