# CVE-2014-125110: wp-file-upload Plugin wfu_ajaxactions.php wfu_ajax_action_callback cross site scripting

> A cross-site scripting vulnerability in the wp-file-upload WordPress plugin allows remote attackers to inject malicious scripts via the wfu_ajax_action_callback function.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 31 Mar 2024
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-8x2p-m64p-q55q

## What is CVE-2014-125110?

CVE-2014-125110 is a low-severity cross-site scripting vulnerability in wp-file-upload Plugin, published on 31 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability has been found in wp-file-upload Plugin up to 2.4.3 on WordPress and classified as problematic. Affected by this vulnerability is the function wfu_ajax_action_callback of the file lib/wfu_ajaxactions.php. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 2.4.4 is able to address this issue. The identifier of the patch is c846327df030a0a97da036a2f07c769ab9284ddb. It is recommended to upgrade the affected component. The identifier VDB-258781 was assigned to this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2014-125110?


## How do I fix CVE-2014-125110?

No fix has been published for CVE-2014-125110 yet. Limit exposure of the affected software until one is available.

## Is CVE-2014-125110 being exploited?

There is no known exploitation of CVE-2014-125110 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-125110 and fix it if it is affected.

What it is: CVE-2014-125110 is a low-severity cross-site scripting vulnerability in wp-file-upload Plugin, published on 31 Mar 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-125110 in the wild and no public exploit code.

Affected product: wp-file-upload Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-125110/ (Markdown: https://insights.sbomify.com/CVE-2014-125110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-125110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-125110
- OSV: https://osv.dev/vulnerability/CVE-2014-125110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-125110/
Summaries are generated and may contain mistakes; the official description above is the record.
