CVE-2014-125111 namithjawahar Wp-Insert cross site scripting

Low 3.5 Published Updated

Remote attackers can inject malicious scripts into the Wp-Insert WordPress plugin, potentially compromising user sessions or site integrity.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2014-125111?

CVE-2014-125111 is a low-severity cross-site scripting vulnerability in namithjawahar Wp-Insert, published on 8 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in namithjawahar Wp-Insert up to 2.0.8 and classified as problematic. Affected by this issue is some unknown functionality. The manipulation leads to cross site scripting. The attack may be launched remotely. Upgrading to version 2.0.9 is able to address this issue. The name of the patch is a07b7b08084b9b85859f3968ce7fde0fd1fcbba3. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-259628.

Weakness: CWE-79

Which versions are affected by CVE-2014-125111?

How do I fix CVE-2014-125111?

No fix has been published for CVE-2014-125111 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2014-125111 being exploited?

There is no known exploitation of CVE-2014-125111 in the wild and no public exploit code.

Sources

Also known as GHSA-rpxx-wr6g-h998.

Is CVE-2014-125111 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free