{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2014-125111 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2014-125111 yet. Limit exposure of the affected software until one is available.","what":"CVE-2014-125111 is a low-severity cross-site scripting vulnerability in namithjawahar Wp-Insert, published on 8 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-125111 and fix it if it is affected.\n\nWhat it is: CVE-2014-125111 is a low-severity cross-site scripting vulnerability in namithjawahar Wp-Insert, published on 8 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-125111 in the wild and no public exploit code.\n\nAffected product: namithjawahar Wp-Insert. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-125111/ (Markdown: https://insights.sbomify.com/CVE-2014-125111/index.md)","id":"CVE-2014-125111","markdown":"https://insights.sbomify.com/CVE-2014-125111/index.md","name":"CVE-2014-125111","record":{"aliases":["GHSA-rpxx-wr6g-h998"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Remote attackers can inject malicious scripts into the Wp-Insert WordPress plugin, potentially compromising user sessions or site integrity.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability was found in namithjawahar Wp-Insert up to 2.0.8 and classified as problematic. Affected by this issue is some unknown functionality. The manipulation leads to cross site scripting. The attack may be launched remotely. Upgrading to version 2.0.9 is able to address this issue. The name of the patch is a07b7b08084b9b85859f3968ce7fde0fd1fcbba3. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-259628.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"namithjawahar Wp-Insert cross site scripting","id":"CVE-2014-125111","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2014"},"n_packages":0,"n_references":3,"next":{"headline":"Plack::Middleware::Session::Cookie versions through 0.21 for Perl allows remote code execution","id":"CVE-2014-125112"},"packages":[],"prev":{"headline":"wp-file-upload Plugin wfu_ajaxactions.php wfu_ajax_action_callback cross site scripting","id":"CVE-2014-125110"},"products":["Wp-Insert"],"published":"2024-04-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-06","vendors":["namithjawahar"]},"summary":"Remote attackers can inject malicious scripts into the Wp-Insert WordPress plugin, potentially compromising user sessions or site integrity.","url":"https://insights.sbomify.com/CVE-2014-125111/"}