{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-125127 exists.","fix":"No fix has been published for CVE-2014-125127 yet. Limit exposure of the affected software until one is available.","what":"CVE-2014-125127 is a high-severity denial of service vulnerability in flightphp core, published on 3 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-125127 and fix it if it is affected.\n\nWhat it is: CVE-2014-125127 is a high-severity denial of service vulnerability in flightphp core, published on 3 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-125127 exists.\n\nAffected product: flightphp core. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-125127/ (Markdown: https://insights.sbomify.com/CVE-2014-125127/index.md)","id":"CVE-2014-125127","markdown":"https://insights.sbomify.com/CVE-2014-125127/index.md","name":"CVE-2014-125127","record":{"aliases":["GHSA-q996-685m-c683"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP web framework","requires_auth":"none","summary":"Attackers can cause denial of service by sending large payloads that exhaust server memory due to eager loading of request bodies in the Flight PHP framework.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Checkmarx","cpe":[{"product":"flight","vendor":"flightphp"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"The mikecao/flight PHP framework in versions prior to v1.2 is vulnerable to Denial of Service (DoS) attacks due to eager loading of request bodies in the Request class constructor. The framework automatically reads the entire request body on every HTTP request, regardless of whether the application needs it. An attacker can exploit this by sending requests with large payloads, causing excessive memory consumption and potentially exhausting available server memory, leading to application crashes or service unavailability. The vulnerability was fixed in v1.2 by implementing lazy loading of request bodies.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":null,"headline":"Denial of Service (DoS) vulnerability in mikecao/flight","id":"CVE-2014-125127","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2014"},"n_packages":0,"n_references":3,"next":{"headline":"Cross-site scripting in apostrophecms:sanitize-html","id":"CVE-2014-125128"},"packages":[],"prev":{"headline":"Simple E-Document Arbitrary File Upload RCE","id":"CVE-2014-125126"},"products":["core"],"published":"2025-09-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-03","vendors":["flightphp"]},"summary":"Attackers can cause denial of service by sending large payloads that exhaust server memory due to eager loading of request bodies in the Flight PHP framework.","url":"https://insights.sbomify.com/CVE-2014-125127/"}